PostgreSQL 8.4 problem with Greylist version 1.1 - release 2

Greylist version 1.1 - release 2 doesn't work with PostgreSQL 8.4.
Here's a diff to get it working ($Id: dbdatasource.h 64 2010-08-12 21:58:53Z mimo $):
# diff /tmp/dbdatasource.h ../src/dbdatasource.h
63c63
< _returnFields += "`" + field + "`"; // TODO unless *
---
> _returnFields += field; // TODO unless *
90c90
< if (_query.get_resultf("SELECT " + returnFields + " FROM `"
---
> if (_query.get_resultf("SELECT " + returnFields + " FROM "

Cheers, Toni